PHP

php7.3编译安装时报错system libzip must be upgraded to version >= 0.11

字号+ 编辑: 国内TP粉 修订: 秦朝 来源: 博客园 2018-04-14 22:37:20 我要说两句(0)

用centos6.x编译php7.3常见一错误解决方案。

PHP版本号7.3,报错:

system libzip must be upgraded to version >= 0.11

原来的libzip版本低,需要安装高版本的libzip


首先,yum卸载libzip

yum  -y remove libzip-devel


然后wget下载编译, 命令如下:

wget https://libzip.org/download/libzip-1.3.2.tar.gz
tar xvf libzip-1.3.2.tar.gz
cd libzip-1.3.2
./configure
make && make install

如果是下载1.5.*以上版本,则需要采用如下安装方式


yum -y install cmake
wget https://libzip.org/download/libzip-1.5.1.tar.gz
tar -zxvf libzip-1.5.1.tar.gz
cd libzip-1.5.1
mkdir build
cd build
cmake ..
make && make install


阅完此文,您的感想如何?
  • 鼓掌

    1

  • 鄙视

    0

  • 开心

    0

  • 愤怒

    0

  • 可怜

    0

1.转来的文章都会标好来源,如对来源资料存疑,请邮件声明;
2.本站标注原创的文章,转发时烦请注明来源;
3.如文章侵犯了您的版权,请通知本站,该文章将在24小时内移除。

相关课文
  • pecl安装swoole报错 error

  • php针对mysql的orm: 一个轻量级的pdo操作类

  • shell_exec() has been disabled for security reasons 解决方法

  • PHP框架全部显得多余的4种原因

我要说说
网上宾友点评